ATEN—第六章PPP协议(点对点协议)
本文标签: ATEN 休闲 PPP协议 点对点协议 职场 

实验使用的工具:小凡模拟器
实验一、二、三:(同一幅图)


★任务一:配置PAP★
☆①☆
R1
Router>
Router>enable
Router#config terminal
Router(config)#hostname R1-jin
R1-jin(config)#interface s0/0
R1-jin(config-if)#encapsulation ppp ——配置PPP协议
R1-jin(config-if)#ip address 192.168.1.1 255.0.0.0
R1-jin(config-if)#clock rate 128000 ——配置链路的速率(DCE接口端)
R1-jin(config-if)#ppp authentication pap ——启用PAP认证功能
R1-jin(config-if)#no shutdown
R1-jin(config-if)#exit

R1-jin(config)#username jinliuli password 123 ——添加被认证用户的用户名和密码
R1-jin(config)#end

R1-jin#show interface s0/0

R2
Router>
Router>enable
Router#config terminal
Router(config)#hostname R2-jin
R2-jin(config)#interface s0/0
R2-jin(config-if)#encapsulation ppp
R2-jin(config-if)#ip address 192.168.1.2 255.0.0.0
R2-jin(config-if)#no shutdown

R2-jin(config-if)#ppp pap sent-username jinliuli password 123 ——配置PAP认证所需的用户名和密码
R2-jin(config-if)#end

R2-jin#show interface s0/0 ——查看


任务二:配置CHAP
☆②☆
R1
Router>
Router>enable
Router#config terminal
Router(config)#hostname R1-jin
R1-jin(config)#interface s0/0
R1-jin(config-if)#encapsulation ppp
R1-jin(config-if)#clock rate 128000
R1-jin(config-if)#ip address 192.168.1.1 255.255.255.0
R1-jin(config-if)#ppp authentication chap
R1-jin(config-if)#ppp chap hostname li ——指定用户名,让被认证方使用此名
R1-jin(config-if)#no shutdown
R1-jin(config-if)#exit

R1-jin(config)#username R2-jin password 456
R1-jin(config)#exit

R1-jin#show interface s0/0

R2
Router>
Router>enable
Router#config terminal
Router(config)#hostname R2-jin
R2-jin(config)#interface s0/0
R2-jin(config-if)#ip address 192.168.1.2 255.0.0.0
R2-jin(config-if)#encapsulation ppp
R2-jin(config-if)#no shutdown
R2-jin(config-if)#exit

R2-jin(config)#username li password 456
R2-jin(config)#exit

R2-jin#show interface s0/0


任务三:配置地址协商
☆③☆
R1
Router>
Router>enable
Router#config terminal
Router(config)#hostname R1-jin
R1-jin(config)#interface s0/0
R1-jin(config-if)#ip address 192.168.1.1 255.0.0.0
R1-jin(config-if)#encapsulation ppp
R1-jin(config-if)#clock rate 128000
R1-jin(config-if)#peer default ip address 192.168.1.20
R1-jin(config-if)#no shutdown
R1-jin(config-if)#exit
R1-jin(config)#end
R1-jin#show interface s0/0

R2
Router>
Router>enable
Router#config terminal
Router(config)#hostname R2-jin
R2-jin(config)#interface s0/0
R2-jin(config-if)#encapsulation ppp
R2-jin(config-if)#ip address negotiated
R2-jin(config-if)#no shutdown
R2-jin(config-if)#end
R2-jin#show interface s0/0


实验四:

 

一、R1和R2之间配置PAP
R1
Router>
Router>enable
Router#config terminal
Router(config)#hostname R1-jin
R1-jin(config)#interface s0/0
R1-jin(config-if)#encapsulation ppp
R1-jin(config-if)#ip address 10.0.0.1 255.0.0.0
R1-jin(config-if)#clock rate 128000
R1-jin(config-if)#ppp authentication pap
R1-jin(config-if)#no shutdown
R1-jin(config-if)#exit
R1-jin(config)#username jinliuli password 123
R1-jin(config)#exit
R1-jin#show interface s0/0
R1-jin#ping 10.0.0.2
R2
Router>
Router>enable
Router#config terminal
Router(config)#hostname R2-jin
R2-jin(config)#interface s0/0
R2-jin(config-if)#encapsulation ppp
R2-jin(config-if)#ip address 10.0.0.2 255.0.0.0
R2-jin(config-if)#no shutdown
R2-jin(config-if)#ppp pap sent-username jinliuli password 123
R2-jin(config-if)#end
R2-jin#show interface s0/0
R2-jin#ping 10.0.0.1
能相互Ping通!
二、R3和R2之间配置CHAP
R3
Router>
Router>enable
Router#config terminal
Router(config)#hostname R3-jin
R3-jin(config)#interface s0/1
R3-jin(config-if)#encapsulation ppp
R3-jin(config-if)#ip address 20.0.0.2 255.0.0.0
R3-jin(config-if)#clock rate 128000
R3-jin(config-if)#ppp authentication chap
R3-jin(config-if)#ppp chap hostname haohao
R3-jin(config-if)#no shutdown
R3-jin(config-if)#exit
R3-jin(config)#username R2-jin password 987
R3-jin(config)#end
R3-jin#show interface s0/1
R3-jin#ping 20.0.0.1
R2
R2-jin#config terminal
R2-jin(config)#interface s0/1
R2-jin(config-if)#encapsulation ppp
R2-jin(config-if)#ip address 20.0.0.1 255.0.0.0
R2-jin(config-if)#no shutdown
R2-jin(config-if)#username haohao password 987
R2-jin(config)#end
R2-jin#show interface s0/1
R2-jin#ping 20.0.0.2
能相互ping通!!
OK 实验完成!!!
实验五:


一、R1和R2之间配置PAP;R2和R3之间配置CHAP
R1
Router>
Router>enable
Router#config terminal
Router(config)#hostname R1-jin
R1-jin(config)#interface s0/0
R1-jin(config-if)#encapsulation ppp
R1-jin(config-if)#ip address 10.0.0.1 255.0.0.0
R1-jin(config-if)#clock rate 128000
R1-jin(config-if)#ppp authentication pap
R1-jin(config-if)#no shutdown
R1-jin(config-if)#exit
R1-jin(config)#username jinliuli password 123
R1-jin(config)#exit
R1-jin#show interface s0/0
R1-jin#ping 10.0.0.2
R2
Router>
Router>enable
Router#config terminal
Router(config)#hostname R2-jin
R2-jin(config)#interface s0/0
R2-jin(config-if)#encapsulation ppp
R2-jin(config-if)#ip address 10.0.0.2 255.0.0.0
R2-jin(config-if)#no shutdown
R2-jin(config-if)#ppp pap sent-username jinliuli password 123
R2-jin(config-if)#end
R2-jin#show interface s0/0
R2-jin#ping 10.0.0.1
R3
Router>
Router>enable
Router#config terminal
Router(config)#hostname R3-jin
R3-jin(config)#interface s0/1
R3-jin(config-if)#encapsulation ppp
R3-jin(config-if)#ip address 20.0.0.2 255.0.0.0
R3-jin(config-if)#clock rate 128000
R3-jin(config-if)#ppp authentication chap
R3-jin(config-if)#ppp chap hostname haohao
R3-jin(config-if)#no shutdown
R3-jin(config-if)#exit
R3-jin(config)#username R2-jin password 987
R3-jin(config)#end
R3-jin#show interface s0/1
R3-jin#ping 20.0.0.1
R2
R2-jin#config terminal
R2-jin(config)#interface s0/1
R2-jin(config-if)#encapsulation ppp
R2-jin(config-if)#ip address 20.0.0.1 255.0.0.0
R2-jin(config-if)#no shutdown
R2-jin(config-if)#username haohao password 987
R2-jin(config)#end
R2-jin#show interface s0/1
R2-jin#ping 20.0.0.2
二、分别对3个路由器的F1/0(以太网接口)设置IP,并配置动态路由
R1
R1-jin#config terminal
R1-jin(config)#interface f1/0
R1-jin(config-if)#ip address 30.0.0.1 255.0.0.0
R1-jin(config-if)#no shutdown
R1-jin(config-if)#exit
R1-jin(config)#router rip
R1-jin(config-router)#network 10.0.0.0
R1-jin(config-router)#network 30.0.0.0
R1-jin(config-router)#end
R1-jin#show ip route
R2
R2-jin#config terminal
R2-jin(config)#interface f1/0
R2-jin(config-if)#ip address 40.0.0.1 255.0.0.0
R2-jin(config-if)#no shutdown
R2-jin(config-if)#exit
R2-jin(config)#router rip
R2-jin(config-router)#network 10.0.0.0
R2-jin(config-router)#network 20.0.0.0
R2-jin(config-router)#network 40.0.0.0
R2-jin(config-router)#end
R2-jin#show ip route
R3
R3-jin#config terminal
R3-jin(config)#interface f1/0
R3-jin(config-if)#ip address 50.0.0.1 255.0.0.0
R3-jin(config-if)#no shutdown
R3-jin(config-if)#exit
R3-jin(config)#router rip
R3-jin(config-router)#network 20.0.0.0
R3-jin(config-router)#network 50.0.0.0
R3-jin(config-router)#end
R3-jin#show ip route
三、配置PC,验证:全网通信
VPCS 1 >
VPCS 1 >show
VPCS 1 >ip 30.0.0.2 30.0.0.1 8
VPCS 1 >2
VPCS 2 >ip 40.0.0.2 40.0.0.1 8
VPCS 2 >3
VPCS 3 >ip 50.0.0.2 50.0.0.1 8
VPCS 3 >show
VPCS 3 >ping 40.0.0.2
40.0.0.2 icmp_seq=1 timeout
40.0.0.2 icmp_seq=2 time=94.000 ms
40.0.0.2 icmp_seq=3 time=125.000 ms
40.0.0.2 icmp_seq=4 time=94.000 ms
40.0.0.2 icmp_seq=5 time=110.000 ms
VPCS 3 >ping 30.0.0.2
30.0.0.2 icmp_seq=1 timeout
30.0.0.2 icmp_seq=2 time=125.000 ms
30.0.0.2 icmp_seq=3 time=125.000 ms
30.0.0.2 icmp_seq=4 time=156.000 ms
30.0.0.2 icmp_seq=5 time=156.000 ms
VPCS 3 >1
VPCS 1 >ping 40.0.0.2
40.0.0.2 icmp_seq=1 time=94.000 ms
40.0.0.2 icmp_seq=2 time=93.000 ms
40.0.0.2 icmp_seq=3 time=94.000 ms
40.0.0.2 icmp_seq=4 time=94.000 ms
40.0.0.2 icmp_seq=5 time=141.000 ms
OK   完成!!!

发表于: 2012-07-09 10:29 阅读(394) 评论(0) 收藏 好文推荐

本博客所有内容,若无特殊声明,皆为博主原创作品,未经博主授权,任何人不得复制、转载、摘编等任何方式进行使用和传播。

作者该类其他博文:

发表评论(网友发言只代表个人观点,不代表本网站观点或立场。)

您尚未登录,请先【登录或注册